Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.
His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6
/**//*该题是动态规划中的01背包问题,把最大被抓概率转为安全概率1-p,然后按照背包问题求解即可,注意题目没说是精确到小数点后两位
状态方程:d[i]=0 or max(d[i],d[j-money[i]]*pro[i],要注意是乘法,我看错WA了好久~~~~(>_<)~~~~ */
#include<cstdio>
#include<iostream>
#include<cmath>
#define MAXN 101
#define MAXW 10001
using namespace std;
double max(double a,double b)
{
return a>b?a:b;
}
int money[MAXN];
double d[MAXW],pro[MAXW];
int main()
{
int test,n,i,j,msum;
double p;
cin>>test;
while(test--)
{
scanf("%lf %d",&p,&n);
p=1-p;
msum=0;
for(i=0;i<n;i++)
{
scanf("%d %lf",&money[i],&pro[i]);
msum+=money[i];
pro[i]=1-pro[i];//记得转换数据
}
for(i=0;i<=msum;i++)
d[i]=0;
d[0]=1;
for(i=0;i<n;i++)
for(j=msum;j>=money[i];j--)
d[j]=max(d[j],d[j-money[i]]*pro[i]);//状态方程;
bool flag=false;
for(i=msum;i>=0;i--)
{
if(d[i]-p>0.000000001)//自顶向下找出最大的i;
{
printf("%d\n",i);
break;
}
}
}
return 0;
}
//动态规划基础题。2013、2、16
posted on 2013-02-16 22:15
天YU地___PS,代码人生 阅读(243)
评论(0) 编辑 收藏 所属分类:
acm