随笔 - 11  文章 - 2  trackbacks - 0
<2024年12月>
24252627282930
1234567
891011121314
15161718192021
22232425262728
2930311234

常用链接

留言簿

随笔分类

随笔档案

文章分类

文章档案

新闻分类

link

搜索

  •  

最新评论

阅读排行榜

评论排行榜

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4237    Accepted Submission(s): 1165


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
24
39
0
 

Sample Output
6
3
//************************************************程序***********************************************
import java.util.*;

public class hd1013 {

/**
* @param args
*/

public static int fun(String str){
char c[]=str.toCharArray();
int n=0;
for(int i=0;i<c.length;i++){
n+=Integer.parseInt(String.valueOf(c[i])); ;
}
while(n>=10){
int sum=0;
while(n>0){
sum+=n%10;
n=n/10;
}
n=sum;
}
return n;
}
public static void main(String[] args) {
// TODO 自动生成方法存根
Scanner s = new Scanner(System.in);
while (s.hasNext()) {
String str=s.nextLine();
if ( str.equals("0"))
break;
System.out.println(fun(str));
}
s.close();
}
}

//************************************************程序***********************************************
注:本题要注意对于输入保存为字符串
posted on 2008-06-06 14:14 poower 阅读(103) 评论(0)  编辑  收藏

只有注册用户登录后才能发表评论。


网站导航: